Заказ не пришёл в Frontpad — что делать?
Суть проблемы: Заказы с сайта или приложения не поступают в CRM
Решение:
1. Проверьте логи заказа в разделе «Интеграция с CRM» > Frontpad > «Логи заказов».
Вам нужно поле «Ответ» > нажмите «Показать». В коде ответа обратите внимание на последнюю строку — в ней увидите код ошибки. Пример:

- ошибка cash_close говорит о том, что была закрыта смена: чтобы таких ситуаций не было, рекомендуем после закрытия смены сразу же открывать новую;
- ошибка invalid_product_keys говорит о том, что у товаров в заказе не прописаны артикулы: прописать артикулы нужно в разделе «Интеграция с CRM» > Frontpad > «Сверка артикулов».
- ошибка requests_limit — превышен лимит запросов: система 5 раз попробует повторить заказ, это будет видно по одинаковому id заказа.
2. Проверьте, указаны ли артикулы для товаров во всех заказах, которые не пришли в CRM.
если артикула нет на одном товаре — такой товар не будет указан в заказе в CRM; если артикулов нет на всех товарах — заказ не придёт совсем.
3. Если артикулы проставлены, но товар не отображается в заказе в CRM, проверьте, есть ли такой товар в самой CRM. Возможно, товар был случайно удалён. Если товара нет, его нужно создать и прописать соответствующий артикул. Артикулы в админ-панели и в CRM должны совпадать.
Пришло сообщение, что заказ не попал в Frontpad (тариф не поддерживает API).

Причина:
У вас слетел (не оплатился) тариф во Frontpad и сменился на бесплатный без поддержки API.
Решение:
1. Оплатите или измените тариф во Frontpad на “Профессиональный” в нем по-умолчанию включен API или “Корпоративный” в нем нужно подключить API как доп. опцию.

2. После заново включите интеграцию в админ-панели платформы: Интеграция с CRM > Frontpad > Общие настройки.

3. Нажмите “Сохранить” внизу страницы.

4. Перейдите в “Заказы” и нажмите “Повторить” (1) у не попавших в Frontpad заказов.

Пришло сообщение, что заказ не попал в Frontpad (неверный ключ API).

Причина:
Кто-то изменил / обновил ключ API в настройках Frontpad, возможно, случайно.
Решение:
Скопируйте ключ API из Frontpad в настройки Food Ninja.
1. Для этого перейдите в Frontpad > Настройки > Общие > API.

2. Далее нажмите скопируйте «Секрет» (1).

3. Перейдите в админ-панель Food Ninja > Интеграция с CRM > Frontpad.

4. Скопированный ключ вставьте в поле «API ключ Frontpad» (2), отметьте галочкой “Включить интеграцию” (1) и нажмите “Сохранить” внизу страницы.

5. Перейдите в “Заказы” и нажмите “Повторить” (1) у не попавших в Frontpad заказов.

Вопросы и ответы
Вопрос– Если человек скачает приложение , он появится в фронпаде?
Ответ – Нет, только после оформления первого заказа.
Вопрос – У некоторых клиентов во фротнпаде есть свои комментарии (например, обязательно брать предоплату с человека). Когда этот клиент делает заказ на нашем сайте/в приложении, такой комментарий не отображается. Есть возможность синхронизировать клиентские базы или что-то еще сделать, чтобы комментарии по клиентам были и при заказе через нашу платформу?
Ответ – Указать его данное инфо у нас на платформе, в разделе “Клиенты#, тогда он будет приходить в примечании к заказу.

На данный момент импорт комментария не поддерживается, добавим данную опцию в новой версии платформы.
Интеграция с Frontpad была отключена, не оплачен тариф
Видим, что интеграция с Frontpad была отключена, так как не оплачен тариф.
Когда оплатите тариф, включите интеграцию снова в настройках админ-панели: «Интеграция с CRM» > Frontpad > «Общие настройки» > поставьте галочку напротив «Включить интеграцию».
Во Frontpad заказ пришел без скидки
Проверьте, пожалуйста, что в карточке товара во Frontpad установлена галочка рядом с пунктом «Изменение цены в заказе» и *действуют скидки* на товарах со скидкой и которые по промокоду и из шкалы подарков.

Нет статуса готов, статус заказа не показывается в личном кабинете клиентов.
По правилам Frontpad, можно указать не более 5 статусов для синхронизации.
Вам нужно один из действующих статусов поменять на готов.
